Kurinchi Blogger Scribbles …


Dec 21
2016

Python PIP install: Insecure platform warning

Last updated: December 21st, 2016

Normally, installing a python module and its dependencies is done via Pip. If HTTPS is blocked in private networks, then things might get tricky and you get the following message.

InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3 from configuring SSL appropriately and may cause certain SSL connections to fail.

To bypass this, you can issue the below command to trust pypi.python.org

$ pip install –trusted-host pypi.python.org Flask

To make sure that the needed module is installed, check it by

$ pip freeze

Tags: , , , , , ,

Leave a Reply


Valid HTML 4.01 Strict  Valid HTML 4.01 Strict